Recursive route

May 27, 2008 22:13

I'm quite upset with myself for forgetting how to get around this issue from my class a couple of weeks back. Topology as follows

Router 1 sits in OSPF area 0. Router 1 runs Rip to Router 6. Router 6 has OSPF area 10. Now we all know that area 10 needs to get to area 0 somehow. The logical choice is a nice tunnel interface on both sides:

Router 6:
interface Tunnel0
ip address 172.22.61.6 255.255.255.0
ip ospf 1 area 10
tunnel source Loopback0
tunnel destination 1.1.1.1
tunnel mode ipip

Router 1:
interface Tunnel0
ip address 172.22.61.1 255.255.255.0
ip ospf 1 area 10
tunnel source Loopback0
tunnel destination 6.6.6.6
tunnel mode ipip

Now when all of that is put in I start getting messages that the Tunnel 0 interface is going down due to recursive routing, and my OSPF adjacencies are bounding up and down. Normally you could use a static route to get rid of that, but I'm not allowed to do that. I think the fix had something to do with the cost/metric/distance, but damned if I can't find it.

I'm talking to you thegameiam.
Previous post Next post
Up